GIS Viewer Browser Compatibility

The Amherst Maps interface is now fully compatible with all modern browsers, including:
  • Internet Explorer 8 or higher (MS Windows)
  • Safari (Mac)
  • Chrome (all operating systems and devices)
  • Mozilla Firefox 4 or higher
Read our Amherst Maps 4.0 Launch Blog Post for more details about compatibility.

Attention users of Internet Explorer 8 or higher
If you are running Internet Explorer 8 or above, make sure your browser is set to standards mode:
  1. Press the F12 key.
  2. In the panel that pops up, change Browser Mode to the highest version of Internet Explorer available without Compatibility View
  3. Change Document Mode to the same version of Internet Explorer in Standards Mode (Page default).
  4. Close the panel.
  5. Go to the website again and it should work properly.